How to resolve the following error message: “Could not validate SAML assertion.”

A X.509 certificate is needed to authenticate identity and keep your data safe. 

You may see the following error message if your X.509 certificate is approaching expiration or has already expired: “Could not validate SAML assertion.”

The best way to resolve this error message is to request a new certification from your identity provider and then upload it your admin console.

To upload a new X.509 certificate to your team:

  1. Sign in to dropbox.com.
  2. Click on Admin console.
  3. Click Settings.
  4. Click Single sign-on. 
  5. Click on the link to the right of the X.509 certificate.
  6. Select your new certificate from your hard drive and click Open. 
  7. Click Save. 
How helpful was this article?

We’re sorry to hear that.
Let us know how we can improve:

Thanks for your feedback!
Let us know how this article helped:

Thanks for your feedback!

Community answers