Why do I need to upgrade to OS X 10.6.8?

To ensure that your computer is compatible with the Dropbox desktop app we recommend that you use the most up-to-date version of your operating system.

While Dropbox works with OS X 10.6 (Snow Leopard), it requires the most recent version: 10.6.8. If you’re running an older version of OS X 10.6, you may be prompted to update to version 10.6.8. You can update to this version by following these Apple Support instructions.

Did this article answer your question?

We’re sorry to hear that. Let us know how we can improve:

Thanks for your feedback!

Community answers
    Community answers

      Other ways to get help

      Community

      Twitter support

      Guided help