Issues installing a previous version of the Dropbox application

If you're trying to install a previous version of the Dropbox desktop application, you'll likely encounter one of these error messages:

  • You already have a more recent version of Dropbox installed on your machine
  • This installer is no longer supported. Please download a new version from /downloading

If you're encountering an error message, or if you're having trouble installing the Dropbox desktop application, visit our downloads page and install the latest version of Dropbox.

Note: We don't recommend using previous versions, as the latest version includes the most up-to-date fixes and security updates. You should only downgrade to a previous version of Dropbox if instructed to do so by a member of the Dropbox support team

Did this article answer your question?

We’re sorry to hear that. Let us know how we can improve:

Thanks for your feedback!

Community answers
    Community answers

      Other ways to get help

      Community

      Twitter support

      Guided help